• Howdy! Welcome to our community of more than 130.000 members devoted to web hosting. This is a great place to get special offers from web hosts and post your own requests or ads. To start posting sign up here. Cheers! /Peo, FreeWebSpace.net

Firefox / Yahoo question


I'm on a boat
I think this is an interesting problem.

No Yahoo pages will load in Firefox at home for me. I've reinstalled, updated, check blocked sites/add-ons/etc - no logical reason why Yahoo sites should be blocked, but they are. (I actually had to change my personal e-mail from Yahoo to Hotmail because I just couldn't access it.)

Yahoo loads in other browsers no problems at all, and it loads on my husband's PC (which has identical settings and add-ons etc).

It's not such a huge deal anymore, after switching my e-mail, but I'm still curious why it does it, or what a fix might be.

When I try to load a Yahoo site, Firefox just hangs there. The progress/loading bar jams, and it will just sit there forever not loading, while everything else loads immediately in other tabs. But if I open IE/Safari/Opera, Yahoo opens instantly. I never see an error message or anything, just a hanging page...


I'm on a boat
Interesting. I think I've checked most of what this thread says..

I'm pretty sure I did the Spybot thing, but I'll run it again tonight and see. Thanks!

update: Running Spybot now, I'll update with results etc :).
Last edited:


-Team WebLyte-
It could be a jam in between Firefox and possibly any registry settings, use of Revo Uninstaller (freeware) can easily fix this. Another place I would check would be firewall entries for the application itself.

Outside of this, I'd disable all addons within firefox, restart the browser and see if it works then, if so, then re-enable addons until the problem resurfaces and you'll know which addon is possibly causing this.

If that didn't fix it, then figure when the problem began and notice system changes since, especially any browser component updates.

Hope you get this resolved and hopefully you've got G-Mail now ;-)